Creating First Angular 2 App

Hello All. So today I am going to show you all how to create your first Angular2 App. I provided a link to Angular’s 5 Min Quickstart.

Here are some prerequisites I recommend installing.

  • Node.js at least version 4. I have 6.3.0  and npm version 3.10.3

You will need a package.json file

{
“name”: “angular2-quickstart”,
“version”: “1.0.0”,
“scripts”: {
“start”: “tsc && concurrently \”npm run tsc:w\” \”npm run lite\” “,
“lite”: “lite-server”,
“postinstall”: “typings install”,
“tsc”: “tsc”,
“tsc:w”: “tsc -w”,
“typings”: “typings”
},
“license”: “ISC”,
“dependencies”: {
“@angular/common”: “2.0.0-rc.4”,
“@angular/compiler”: “2.0.0-rc.4”,
“@angular/core”: “2.0.0-rc.4”,
“@angular/forms”: “0.2.0”,
“@angular/http”: “2.0.0-rc.4”,
“@angular/platform-browser”: “2.0.0-rc.4”,
“@angular/platform-browser-dynamic”: “2.0.0-rc.4”,
“@angular/router”: “3.0.0-beta.1”,
“@angular/router-deprecated”: “2.0.0-rc.2”,
“@angular/upgrade”: “2.0.0-rc.4”,
“systemjs”: “0.19.27”,
“core-js”: “^2.4.0”,
“reflect-metadata”: “^0.1.3”,
“rxjs”: “5.0.0-beta.6”,
“zone.js”: “^0.6.12”,
“angular2-in-memory-web-api”: “0.0.14”,
“bootstrap”: “^3.3.6”
},
“devDependencies”: {
“concurrently”: “^2.0.0”,
“lite-server”: “^2.2.0”,
“typescript”: “^1.8.10”,
“typings”:”^1.0.4″
}
}